AdRotator doesn't serve ads until TimeSpanPicker (a Coding4Fun control) is opened

Aug 3, 2013 at 3:07 PM
I am currently working on an app that uses the TimeSpanPicker control from the Coding4Fun toolkit. Weirdly enough, my (two) AdRotator controls only begins to serve ads when the TimeSpanPicker control is used, otherwise the AdRotator controls remain blank. The app I'm working on consists of mainly two Pivot pages in which I have placed two separate AdRotator controls (one for each pivot). I invalidate both controls in the same MainPage_Loaded event handler. I have already tried removing one of the controls, leaving only one AdRotator control in the app and I still get the same problem. Any ideas what the issue could be?
Aug 3, 2013 at 4:48 PM
Unless te contents of your pivot pages are separate controls there isn't much point having two separate controls, just create a grid on the page where the pivot is used having the pivot in row 0 and adrotator in row 2

As for why it's not showing ads, that possible because you are not calling "Invalidate" in your pages "Loaded" event.

Check your implementation against the sample apps and check everything is the same.

Hope this helps
Aug 4, 2013 at 3:14 AM
I did call Invalidate for both controls so that wasn't the issue. However, I took your advice and used just one AdRotator control for both pivots and it's working perfectly. Thank you very much!