XNA 0.5

May 6, 2013 at 5:04 PM
Probably there is a problem with DefaultHouseAdImage - I tested my application and it does not show defaulthouseAd (I changed phone into plane mode to test house ad). But If I replace 0.5 with 0.4 without changing anything in the code, ads is visible. I have also tested project included in archive with 0.5 and it also does not work...
Best regards,
May 8, 2013 at 12:30 PM
Right, found a bug in 0.5 due to the removal of the network detection. Basically it never tried to get ads because there was no network ;-(

Easily solved and also patched in the Silverlight version (wasn't causing an issue there for some reason)

However in testing the fix I found a new issue with the Remote House Ad support. For some reason the logic which has worked (forever) now is failing, I suspect they changed something in the WP7 platform. Testing continues.

Putting it simply, when using Texture2D.FromStream in another thread it is now causing a "System.InvalidOperationException", the stream is valid and so is the graphics device and never had an issue before with it, damn frustrating.
Will either try and revolve it or pull remote house ads for XNA for now.