WP7 XNA + Inneractive clicks not going through(?)

Feb 28, 2013 at 1:22 AM

I just integrated the AdRotator with a small project I'm working on and ran into a problem. Then again, since I have not used Inneractive adds before, maybe this is just a stupid user error.

All-in-all, my configuration file sets the InnerActive to 100 probability with my own AppId that was copy-pasted from NAX:
    <AdCultureDescriptor CultureName="default">
      <Probabilities Probability="100" AdType="InnerActive" AppID="MY_APP_ID_HERE" />
I also set it manually in the initialization code
AdRotatorXNAComponent.Current.InneractiveAppId = "MY_APP_ID_HERE";
I have commented out the SettingsUrl as I don't have an online settings file for this. I get the adds to show up and tapping on them takes me to the web browser and to the appropriate site (or store site).

Problem, however, is that when I go to InnerActive (NAX) dashboard, all I see is "Requests" and Clicks says I am still at 0. I am not sure but the amount of Requests might also be smaller than the times I've actually tapped on the ad. I've tried this on both emulator and device. The project is XNA and I'm using the location based version of the library.

Any pointers as to where I can start debugging this as I have no idea why the clicks don't show up in the dashboard. Is there a long delay? Does it block taps from a single device? Does it not work in emulator? Any ideas? I'm clueless here.
Feb 28, 2013 at 2:05 PM
To be honest, this was my own experience with Inneractive, only ever saw impressions and not clicks.

We've implemented the control as it comes from Inneractive fro Nokia. A good test would be to just add the Inneractive control to your app manually and see if you get the same results from Inneractive.

Also note, it's best to put your APP ID in ONE place, putting it in the XAML will override any config in the config XML, so choose one and stick with it.
Mar 2, 2013 at 3:21 AM
Hello, the clicks do seem to go through but the fillrates are really low (still working on this). Another issue I ran into here was that when I switched from InnerActive to pubcenter (I had a working pubcenter code before but i replaced it with adrotator), and it doesn't show anything.

The only change I did was that I changed the probability line from
   <Probabilities Probability="100" AdType="InnerActive" AppID="MYCOMPANY_MYAPP_WP" />
  <Probabilities Probability="100" AdType="PubCenter" AppID="MY_APP_ID" SecondaryID="AD_UNIT_ID" />
Considering the Ad system worked before, I know I "can" receive ads from pubcenter. The code for initializing the adrotator is pretty much the same as in the documentation here. Upon starting, I call invalidate() once (as every time i hide an ad).

My procedure for hiding and showing ads is this:
        public static void EnableAds()
            AdRotatorXNAComponent.Current.Enabled = AdRotatorXNAComponent.Current.Visible = true;

        public static void DisableAds()
            AdRotatorXNAComponent.Current.Enabled = AdRotatorXNAComponent.Current.Visible = false;
Any ideas? I know it's a little bit aside the original subject, I can make a new conversation for it if necessary.
Mar 2, 2013 at 3:32 AM
Nevermind, I figured this out partly (let this be a journal to those struggling with same issues).

I had manually set the width and height for the adds retaining the original aspect ratio. Apparently this affects the fetch or rendering code (i'm guessing the first). If I set the size to 480x80, it loads correctly. However, I have the issue (was mentioned in another thread) of old ad locations displaying another ad when another view tries to show them at another one, resulting in multiple ads displaying all over the map when ever i try to show just one.

Any insight as to how this is done, I thought 300x50 should also be a valid size for an ad from pubcenter but no ad appears with these. Am I limited to 480x80 ?