New Pubcenter SDK

Sep 23, 2013 at 11:11 AM

As Microsoft released a new pubcenter SDK few days ago I tried to update my app with it, but it seems that adrotator (v1.0.3) is not able to load the new assemblies by itself and I end up with a FileLoadException.

Is there any way for me to make it work except by downloading the sources? Do you plan to update the nuget package anytime soon?

Best regards
Sep 23, 2013 at 1:34 PM
We always try to keep up with providers as best we can. We have a final release planned for V1 with some improvements suggested by the community so we can add this in as well.

If you want it quickly then source will be your only option since we are a very small team with big commitments at the mo but we will get to it as soon as we can.
P.S. don't forget there is the alpha package as well.

Failing that you could try the V2 control
Sep 24, 2013 at 10:24 AM

I'm not complaining here, you guys have already done one hell of a job, and I just wanted to be sure there was no easy way to do this before digging into the project sources.

Sep 24, 2013 at 10:31 AM
I'll see if I can find a bit of time today to refresh V1 today and see what I can come up with by the end of the week.
Sep 27, 2013 at 7:00 PM
The updated NuGet packages are on
There's an issue with NuGet at the mo so I cannot upload them so you will have to use them as local packages for now, if you check the docs in that folder there is a section to tell you how to do that if you are not familiar.
Hope this helps
Sep 30, 2013 at 9:35 AM
That's great thank you

The new package does not seem to appear in NuGet using the instructions provided in the doc.

Anyway I'm in no hurry, so I'll just wait for you to find the time to update the official package.
Oct 1, 2013 at 3:27 PM
It's updated on NuGet now, just be sure to use the -pre or select "include Prerelease" when searching for the packages.
Both are version 1.1-beta
Oct 2, 2013 at 5:43 AM
Edited Oct 2, 2013 at 7:09 AM
I tried upgrading to AdRotatorWP.1.1.0-Beta but for some reason no ads are showing up in the app now. I tried using test_client and Image480_80 but no ads show up either (I configured everything to only use PubCenter). I am adding the AdRotatorControl via code and calling Invalidate on OnLoaded (I tried moving this to XML but same result). It used to work before I upgraded to the Beta release.

Any ideas on what might be wrong or how I can debug into this? I don't see any debug output in the console.

My AdControl's width and height are set to 480x80

Oct 2, 2013 at 2:40 PM
To debug just output the Log event from AdRotator to the Debug Window, like so:
AdRotatorControl.Log += (s) => Debug.WriteLine(s); //(ensuring you add a reference to System.Diagnostics)

What we recommend with issues on a single provider, is to add the control manually to your XAML and checking if you get any ads. Invariably with PubCenter these days you do not. Also check on a device and not just the emulator as some providers block showing on an emulator)

Hope this helps
Oct 7, 2013 at 6:42 AM
Works for me now. I was setting Visibility = Collapsed on the control. Before, the control used to animate in even when visibility was collapsed. I got rid of that line and everything works again.
Oct 7, 2013 at 9:21 AM
Yes, if you set Visibility = Collapsed the control won't even start because it assumes it is disabled.
Nov 14, 2013 at 8:26 PM
ok I have tried everything to get it to work. I made a new test app and install the beta. Then I added to the xaml like so.
    AutoStartAds="True" />
But it tells me that LocalSettingsLocation and AutoStartAds are not available. It thinks that these two are not part of adRotator. How can I fix this? another question is when is it planned that Ad Rotator will be finalized? Or a more stable version would be released? Thanks.
Nov 18, 2013 at 12:18 PM
:D, LocalSettings and AutoStartAds are part of the V2 version of AdRotator, NOT V1.

V2 is still in Alpha stage at present but is also available on NuGet as a pre-release.

Are you using the version you intended to?
Nov 18, 2013 at 7:23 PM
I erased those two that caused the problems and it works now. The only thing is that it shows the whole <adRotator :...... /> underlined as if the syntax is wrong. It compiles correctly and I can see the ads working fine but the syntax shows up as error. Is that a know alpha thing? Also have another question. Do Inmobi ads work with this release because not matter what I do it does not work. Pubcenter, Adduplex, House Ads, Interactive and Smatto work but Inmobi does not. Is this an alpha thing as well or is something wrong with my side? Thanks for your previous response. I cant wait to implement your finalized AdRotator. I have 2 million downloads waiting for the update. :)
Nov 18, 2013 at 7:59 PM
The XAML interpreter has started inspecting the control badly again, this is a known issue. You are right it has no effect on the code so it is just an annoyance for now, will get that fixed again.

InMobi should work in the latest releases, we added it at the same time we added it to V2
Nov 18, 2013 at 8:50 PM
I have all these people that updated to the new app but Inmobi shows zero requests. That's impossible since there are over million users. I know this is not related to Ad Rotator but since you got it working for InMobi can you paste a copy of your code that worked for Inmobi? Or maybe there is some special rule or capability that I need to implement to get it working? Thanks. By the way good job with AdRotator been using it since day one. :)
Nov 18, 2013 at 9:38 PM
If you download the source there is an example app in there, there's no additional code to get InMobi working, just add the dll to your project and add inMobi to your configuration .

In the example, just set the probability to 100 to show only InMobi ads, same will work for your app provided your InMobi acount is live and showing ads (test by trying the InMobi control in a blank project manually)