I couldn,t run ad of mobfox on adrotator even i hosted my defaultAdSettings.xml

Aug 2, 2013 at 1:11 AM
I have implemented mobfox using mobfox control in testmode its working showing banner.
But in Ad rotator I have given its Appid (tried alot) and mobfox testmode true but no banner is showing here my code is below:

xaml:
<adRotator:AdRotatorControl x:Name="AdRotatorControl" Width="480" Height="80" Grid.Row="5" Grid.ColumnSpan="3"
        DefaultSettingsFileUri="/window phone;component/defaultAdSettings.xml"
       SettingsUrl="http://xaml.xp3.biz/defaultAdSettings.xml"
        DefaultAdType="MobFox"
        MobFoxAppId="7b1d9417129c829232c3c37a089433d9" MobFoxIsTest="True" 
            SlidingAdDisplaySeconds="10"
            SlidingAdHiddenSeconds="20"
        />
code:
private void MainPage_Loaded(object sender, RoutedEventArgs e)
    {

        if (AdRotatorControl.IsInitialised)
        {
            AdRotatorControl.Invalidate();
        }





    }
Coordinator
Aug 2, 2013 at 2:37 PM
have you tried replacing the settings in one of the test projects to check your settings.
We've had no other reported issues with mobfox at present.

P.S.
It's recommended you place your ad provider configuration within the configuration XML rather than in the XAML as this will override any changes you make.
Aug 2, 2013 at 3:19 PM
Thanks for Quick reply.
I have tried but the problem is when I added this { AdRotatorControl.Invalidate(); } line in loaded function it give me an exception shown below:

An unhandled exception of type 'System.TypeLoadException' occurred in rotator.dll

when I added this
if (AdRotatorControl.IsInitialised)
    {
        AdRotatorControl.Invalidate();
    }
the program is running but adrotator doesnot show mobfox test ad in window.
Coordinator
Aug 2, 2013 at 11:26 PM
Hmm, sounds like something is not right with the way you have implemented it then if it is causing an exception on invalidate.

By adding the code around it you have effectively disabled it because invalidate is never called, the wrapper was for situations where you needed to control when the page was returned to.

Try putting your config in one of the sample apps and prove it's displaying ads, then check your implementation against the sample to check everything is in place.

Also check you have the latest MobFox dll registered in your application as well for Windows Phone
Aug 4, 2013 at 10:02 AM
I have implemented in samples set my xml configuration but the problem is it is giving an exception
system.xml.pdb not loaded
what should I do am so confuse.please help me out.tell me step by step how to use adrotator sir
Thanks
Aug 5, 2013 at 9:26 AM
I am also having problems with MobFox... testmode or live neither seem to show the ads.

I actually have the adRotator live on one of my Apps now and its showing ads for all of the other providers but on my MobFox dashboard im seeing lots of 'Ads Served' but 0 impressions... looks like its receiving the ad but not showing them.

Ive tested the samples of XNA 0.4 and XNA 0.5 and neither sample shows MobFox either. Looking at MobFoxs blog they added the 'Ad Served' metric in February could be something to do with that? http://blog.mobfox.com/