Duplicate Pubcenter Ads (XNA)... Possible Fix.

Jul 30, 2013 at 9:14 AM
Edited Jul 30, 2013 at 9:15 AM
Hey, ive attempted to use the XNA AdRotator before but kept on having problems with duplicate PubCenter ads showing after calling Invalidate() and ended up using my own solution til now.

It seems that a second pubcenter ad is attempting to load over the original which causes both to fail and then an alternate ad provider is shown... you can see 2 copies of the pubcenter ad briefly flashing up and then they get covered up, it quite often seems to freeze the rotator on a single ad until the application is restarted after this happens too.

Ive hopefully managed to fix it by just removing the first pubcenter ad before attempting to load a new one.

At the top of the CreateAd() Method in AdRotatorXNA.cs add this:

if (bannerAd != null)
AdGameComponent.Current.RemoveAd(bannerAd);


This is in V0.5.
Coordinator
Jul 30, 2013 at 10:35 AM
That is very odd, never had that situation in tests but I guess they could have changed something in their later releases.

Sure we can add that to the branch for the final drop of V1.

For now use the source and use your fix.
Jul 30, 2013 at 7:53 PM
Edited Jul 30, 2013 at 7:55 PM
I first tried it back in December and had the same problem, pubcenter is my main network that's why ive avoided using the rotator so long. I really want to get NAX and MobFox implemented properly now so putting the effort in to get it working :)

Im testing on a WP7 Lumia 800... could be something to do with the device?