MobFox - ArgumentNullException

May 27, 2013 at 8:05 PM
Edited May 27, 2013 at 8:05 PM
I added MobFox to my config:

<Probabilities Probability="100" AdType="MobFox" AppID="<app id here>" IsTest="false" />

However, I get an ArgumentNullException when calling InValidate(),
with stacktrace:
A first chance exception of type 'System.ArgumentNullException' occurred in System.Windows.ni.dll
   at System.Windows.PresentationFrameworkCollection`1.AddDependencyObject(DependencyObject value)
   at System.Windows.Controls.UIElementCollection.AddInternal(UIElement value)
   at System.Windows.PresentationFrameworkCollection`1.Add(T value)
   at AdRotator.AdRotatorControl.Invalidate(Boolean selectNextAdType)
   at AdRotator.AdRotatorControl.FinishLoadingSettings()
   at AdRotator.AdRotatorControl.LoadAdSettings()
   at AdRotator.AdRotatorControl.Invalidate(Boolean selectNextAdType)
I tried debugging with Reflector, but I can't see what is going wrong (Reflector does not attach, although I have decompiled the assemblies)...
It seems the AdControl created by CreateMobFoxControl is null? The strange thing is, I get some requests on MobFox...
I am entering the publisher ID as found in Sites/Apps -> Integration.

What am I doing wrong?
Coordinator
May 27, 2013 at 9:32 PM
If you download the sample app from the codeplex site and add your config to it do you get the same error?

From: [email removed]
Sent: ‎27/‎05/‎2013 20:05
To: [email removed]
Subject: MobFox - ArgumentNullException [wp7adrotator:445119]

From: Bobbyware

I added MobFox to my config:

<Probabilities Probability="100" AdType="MobFox" AppID="<app id here>" IsTest="false" />

However, I get an ArgumentNullException when calling InValidate(),
with stacktrace:
   at System.Windows.PresentationFrameworkCollection`1.AddDependencyObject(DependencyObject value)
   at System.Windows.Controls.UIElementCollection.AddInternal(UIElement value)
   at System.Windows.PresentationFrameworkCollection`1.Add(T value)
   at AdRotator.AdRotatorControl.Invalidate(Boolean selectNextAdType)
   at AdRotator.AdRotatorControl.FinishLoadingSettings()
   at AdRotator.AdRotatorControl.LoadAdSettings()
   at AdRotator.AdRotatorControl.Invalidate(Boolean selectNextAdType)
I tried debugging with Reflector, but I can't see what is going wrong (Reflector does not attach, although I have decompiled the assemblies)...
It seems the AdControl created by CreateMobFoxControl is null? The strange thing is, I get some requests on MobFox...
I am entering the publisher ID as found in Sites/Apps -> Integration.

What am I doing wrong?